[zum Index] [Vorige] [Nächste] Anleitungen und Hilfen
.................... für das INTERNET


3. Zugang zum Internet unter Windows

3.0 Installationanleitungen für Windows 95 - Download

3.1 Das Basisprogramm Trumpet-Winsock (für Windows 3.x)

3.2 Der Browser Netscape ( 13.4.97, Gold-Version 3.01, Link zum Autor: Markus Kölle)

3.3 Filetransfer mit WS_FTP

3.4 Mailing mit Eudora

3.5 Telnet

3.6 Dateisuche mit WARCHIE

3.7 News offline lesen mit Free Agent


3.0 Installationanleitungen für Windows 95 - Download

(von Roland Bernert)

Hier können Sie drei gezippte Installationsanleitungen downloaden:

3.1 Das Basisprogramm Trumpet-Winsock (für Windows 3.x)

Trumpet-Winsock sorgt für die Modemverbindung zum Uni-Rechner lehrer1 und liefert die Protokolle für die Verbindung:


Für Windows95 ist dieses Programm nicht mehr nötig, denn Windows95 enthält schon die entsprechende Winsock-Software. Wie Sie die TCP/IP und CSLIP unter Windows95 installieren können hat Klaus Fanz von der Leopold-Feigenbutz-Realschule in Oberderdingen zusammengestellt. Oben (Kap. 3.0) können Sie auch gepackte Installationsanleitungen von Roland Bernet laden.

Alle Windowsprogramme für's Internet setzen auf diesem Sockel auf. Wenn also z.B. Netscape läuft, kann man jederzeit zum Programmanager wechseln und ein weiteres Programm (z.B. ewan oder ws-ftp) starten.

Trumpet-Winsock kann direkt gestartet werden.
Wenn aber Trumpet-Winsock noch nicht läuft, ruft das erste Internet-Programm, das Sie starten, automatisch das Sockelprogramm auf. Entsprechend beendet das Internetprogramm, das Sie als letztes schließen, auch den Sockel und schließt die Modemverbindung.
(Unter Windows 95 müssen Sie erst die DFÜ-Verbindung herstellen und können dann alle möglichen Internet-Programme starten.)

Vielleicht haben Sie festgestellt, daß die Datenübertragungsrate von Netscape sehr gering ist (auch bei örtlichen Servern nur ca. 180 byte/s). Dies liegt an ungünstigen Eintragungen in der Datei trumpwsk.ini . Laden Sie mit irgendeinem ASCII-Editor (z.B. Windows-notepad) die Datei trumpwsk.ini im Verzeichnis Trumpet und ändern Sie die Eintragungen in den folgenden Zeilen wie angegeben:

vector = 60
mtu = 552
rwin = 8192
mss = 512
rtomax = 60
slip-baudrate = 57600  
slip-compressed = 1

Ich habe nur ein 14400er-Modem. Trotzdem funktioniert's mit der Eintragung 57600. Durch die Kompression sind nämlich höhere Datenübertragungsraten möglich. Ich habe schon 2,5 KB/s = ca. 20000 Baud erreicht. Das heißt natürlich nicht , daß diese hohen Raten immer möglich sind. Manche Fernverbindungen sind je nach Auslastung von vorneherein so langsam, daß die maximal möglichen Transferraten der Modemverbindung nicht mehr erreicht werden können.

Am Ende der Datei trmpwsk.ini finden Sie die Zeilen:

[default vars]
$number=376822
$username=za204
$password=..........

Wenn Sie diese Eintragungen löschen, wird Sie Trumpet-Winsock automatisch beim nächsten Start zur Eingabe auffordern und diese dann wieder am Ende von trmpwsk.ini einfügen. Wenn Sie also z.B. ihr Paßwort geändert haben, löschen sie einfach in trmpwsk.ini die letzte Zeile $password=... .
Oder wenn sich ein anderer Benutzer einloggen will, löschen Sie die beiden letzten Zeilen.

Speichert man auf dem Rechner nur eine Version von trmpwsk.ini ohne den [defaults vars]-Block, kann niemand illegal ins WWW gehen. Jeder legale Benutzer kann sich seine Kopie von trmpwsk.ini auf Diskette halten und diese nach Bedarf ins Verzeichnis von Trumpet kopieren. Nach Ausloggen muß er dann nur die Festplattenkopie wieder löschen.


3.2 Der Browser Netscape (Version 2 und 3)

Bevor Sie mit Netscape sinnvoll arbeiten können, müssen Sie ein paar Einstellungen unter dem Menüpunkt Options machen.

Netscape ist in erster Linie ein Browser zur Darstellung von Web-Dokumenten. Die Gold-Versionen bieten allerdings auch noch die Möglichkeit, Web-Seiten zu schreiben, da sie einen komfortablen WYSIWYG-Editor enthalten.
13.4.97: Hier finden Sie eine Einführung in die Erstellung von HTML-Seiten mit Netscape Gold 3.01 von Markus Koelle.

Was kann man alles im Feld Location eintragen?


Offline-Betrieb von Netscape

Mit Netscape kann man Hypertextseiten (d.h. deren Quelltext) abspeichern. Die will man sich vielleicht später mal in Ruhe anschauen oder man will eigene lokal erstellte Seiten erst mal betrachten, bevor man sie ins WWW einspeist.
Dazu können Sie Netscape 2.x auch ohne Verbindung ins WWW starten. Unter Windows 3.x startet zunächst Trumpet-Winsock. Brechen Sie im Trumpet-Wählfenster mit CANCEL einfach die Verbindung ab.

Mit dem Menüpunkt File / Open File laden Sie dann Dateien auf Ihrer Festplatte, CD-Rom oder Diskette ins Netscape-Fenster. Dateiformate, die Netscape direkt darstellen kann, sind HTML-Dateien, alle reinen Textformate und Bilddateien im Format GIF und JPG.
Relative Links funktionieren auch auf der lokalen Festplatte.

Bei älteren Netscape-Versionen (1.x) führt das Abbrechen der Wählverbindung zu einem Systemfehler. Sie können sich aber mit MOZOCK.DLL , einer veränderten WINSOCK.DLL-Datei, behelfen. Wie das geht, lesen Sie hier.


Mails und News mit Netscape

Ab der Version 2 sind diese Programme in Netscape integriert.

Sie starten Netscape-Mail am einfachsten, indem Sie auf das Briefsymbol ganz unten rechts im Netscape-Fenster klicken.

Das Mailprogramm ist ähnlich organisiert wie das Programm Eudora. Eudora nennt seine internen Mailboxen IN, OUT und TRASH. Netscape nennt sie INBOX, SENT und TRASH.

Eudora hat den Vorteil, daß es nach Mailempfang -oder Versand sofort wieder "offline" geht. Netscape arbeitet "online". Wenn Sie Gebühren sparen wollen, müssen Sie bei Netscape bewußt nach dem Mailempfang die Verbindung kappen. Eudora macht das automatisch. Außerdem funktioniert der Mailteil von Netscape im Gegensatz zu Eudora nur mit der Einstellung, bei der die Mails auf lehrer1 gelöscht werden.

Netscape-Mail hat aber den Vorteil, daß Formatierungen zum Teil berücksichtigt werden:
Http-Adressen werden als anklickbare Links dargestellt und "Attachments" können sofort gelesen und bearbeitet werden, wenn das zugehörige Programm bei den Options von Netscape eingetragen ist (z.B. Winword für Dokumente mit der Endung DOC oder Maple für Dokumente mit der Endung MS).

Für den News-Teil müssen Sie den Menüpunkt Window / Netscape News bemühen. Besser ist aber - was die Gebühren betrifft - der Offline-Newsreader Freeagent.


3.3 Filetransfer mit WS_FTP

WS_FTP funktioniert ähnlich wie der Dateimanager von Windows.
Download von Dateien aus meinem Softwareverzeichnis auf lehrer1 (nur für "za's") mit Hilfe von WS_FTP.

Links sehen sie das Inhaltsverzeichnis des aktuellen Pfades des lokalen Rechner und rechts das Inhaltsverzeichnis des entfernten Rechners (hier lehrer1.rz.uni-karlsruhe.de). Sie können - wie die Buttons zeigen - bei beiden Rechnern Verzeichnisse wechseln, erstellen und löschen, Dateien umbenennen, löschen, betrachten, ...

Dateien werden per Mausklick (für Mehrfachauswahl STRG festhalten) ausgewählt und einfache durch Klick auf die Taste mit dem Pfeil nach links oder rechts kopiert. Vorher sollten Sie angeben (Radiobuttons), ob Sie eine Binär- oder ASCII-Datei transferrieren wollen. Wenn eine Textdatei im Binärmodus übertragen wird, kann es sein, daß Zeilenumbrüche und Tabulatoren nicht mehr stimmen.

Das Programm finden Sie als ZIP-Datei gepackt auf vielen Servern in Deutschland (z.B. hier: ftp://roxi.rz.fht-mannheim.de/pub/msdos/tcpip). Packen Sie die Datei WS-FTP.ZIP in einem eigenen Verzeichnis mit PKUNZIP.EXE oder dem Windows-Programm WINZIP.EXEaus. Ein weitere Installation ist nicht nötig. Sie können in Windows WS_FTP.EXE sofort starten (Besser ist es natürlich, man richtet in der Netscape-Gruppe ein Icon ein).

Wichtige Einstellungen für WS_FTP:

  1. Unter Options / Programm Options sollten Sie folgende Eingaben machen:

    Natürlich tragen Sie Ihre za-Nummer ein.
    Statt notepad können Sie auch einen anderen Textbetrachter wählen.

  2. Unter Options / Session Options tragen Sie ein:

    Falls Dateiendungen automatisch konvertiert werden sollen, müssen Sie hier noch ein Kreuzchen bei Convert Extensions machen.
    Speichern Sie die Options jeweils mit Hilfe des Save-Buttons.

  3. Wenn Ihre HTML-Seiten (mit der DOS-Endung HTM) automatisch beim Transfer die Endung HTML auf dem UNIX-System lehrer1 bekommen sollen, wählen Sie Options / Extension Conversions. Sie erhalten das Fenster:

    Tragen Sie in den beiden oberen Textfeldern ein, wie konvertiert werden soll und fügen Sie die Eintragung dann mit dem ADD-Knopf zur Liste hinzu. Sie können mehrere Konvertierungen festlegen.
    Damit die Konvertierungen auch ausgeführt werden, müssen Sie unter Options / Session Options noch das entsprechende Kreuzchen machen (siehe oben).

  4. Im Connect-Fenster können sie die Daten verschiedener Hosts angeben und abspeichern, mit denen Sie öfters Verbindung aufnehmen wollen. Wenn Sie Dateien zwischen lehrer1 und Ihrem lokalen Rechner übertragen wollen, machen Sie folgende Angaben (mit Ihrer za-Nummer und Ihrem Paßwort):

    Download von Dateien aus meinem Softwareverzeichnis auf lehrer1 (nur für "za's").

    Wollen Sie sich bei einem Rechner anonym einloggen, müssen Sie nur - nach Eingabe der Rechneradresse - Anonymous loggin ankreuzen. Die beiden nebenstehenden Felder werden dann automatisch richtig belegt:


3.4 Mailing mit Eudora

Eudora ist ein komfortables Mailprogramm unter Windows.

Das Programm geht immer nur kurz online und schließt die Verbindung nach dem Mailempfang (oder -Versand) sofort wieder, so daß der Gebührenzähler nicht zu lange läuft.

Bevor Sie Eudora benutzen können, müssen Sie einige Eintragungen und Einstellungen unter dem Menüpunkt Special / Settings machen. Ab Version 1.5.4 heißt dieser Menüpunkt Tools / Options. Ab dieser Version ist auch 32-Bit Software für Windows95 integriert.

Außerdem in dieser Version: Wenn Sie eine Mail lesen, die URL-Angaben (http://...) enthält, können Sie diese Textstellen mit der Maus "Doppelklicken". Ihr Browser startet und zeigt die Seite an, wenn Sie online sind.

Wie arbeitet man mit Eudora?

  1. Organisatorisches
    Eudora organisiert Ihre Mails in drei Fenstern: "In", "Out" und "Trash" (Trash enthält die gelöschten Mails). Diese Fenster werden mit dem Menüpunkt Mailbox nach Bedarf einblendet . Der Inhalt einer Mail wird nach einem Doppelklick auf die entsprechende Zeile angezeigt
    Sie können mit Mailbox / New auch eigene Eudora-Mailboxen erzeugen. Damit ist es möglich, Mails nach Sachgebieten zusammenzufassen, um bei größeren Anzahlen den Überblick zu behalten. Um eine Mail in eine andere Box zu verschieben, wird das entsprechende Mailbox-Fenster geöffnet, die Mail mit der Maus angeklickt und dann im Menüpunkt Transfer die Zielbox gewählt.
    Wenn Sie eine Mail löschen wollen, drücken Sie nach dem Anklicken einfach die Entf-Taste oder benutzen den - Knopf. Die Mail wird dann in die TRASH-Box verschoben. Um eine Mail endgültig zu löschen, müssen Sie sie auch in dieser Box löschen. Oder Sie leeren diese Box komplett mit Special / Empty Trash.
  2. Mails holen und lesen
    Beim Start des Programms werden Sie nach Ihrem Paßwort gefragt, dann loggt sich Eudora auf lehrer1 ein, holt neue Mails, falls Sie welche bekommen haben und öffnet das IN-Fenster, um die Mails anzuzeigen. Ungelesene Mails sind mit einem Punkt markiert. Zum Lesen der Mail, den Eintrag "doppelklicken".
    Durch Anwahl des Menüpunktes File / Check Mail können Sie Eudora jederzeit nach neuen Mails "schauen lassen".
  3. Neue Mail erstellen und abschicken
    Drücken Sie den 1. Knopf in der "Hotbutton"-Leiste:
    Sie erhalten ein Fenster für die Mail-Erstellung. Geben Sie die Adresse des Empfängers an (To:), das Thema Ihres Briefes (Subject:), evtl. Adressaten für Kopien (Cc:) und Dateien, die Sie anhängen wollen (Attachements:). Dann schreiben Sie Ihren Brief im darunterliegenden Textfeld. Über die Zwischenablage können Sie Text von beliebigen anderen Programmen einfügen. Als Attachement können komplette Dokumente mitgeschickt werden, z.B. Word-Dateien. Die kann der Empfänger dann natürlich auch nur mit dem entsprechenden Programm lesen.
    Wenn Sie unter dem Menüpunkt Window / Signature (bzw. ab Version 1.5.4 Tools / Signature) Text eingetragen haben, wird dieser beim Versand automatisch an Ihre Mail angehängt (Falls Sie das nicht im 2. Pull-Down-Menü des Fensters abgeschaltet haben).

    Die anderen 3 Knöpfe obiger Leiste dienen dazu, auf eine markierte Mail zu antworten (Reply), sie weiter- bzw. umzuleiten (Forward bzw. Redirect). Unterschiede:

  4. "Nicknames"
    Häufig benutzte e-mail-Adressen lassen sich unter Kürzeln speichern. Das Nickname-Fenster läßt sich mit dem - Knopf einblenden.
    Um ein neues Kürzel zu vereinbaren, drücken Sie den New-Knopf, geben in dem eingeblendeten Fenster einen Alias ("What do you wish to call it?") ein und kreuzen "Put it to the recipient list" an, bevor Sie ok drücken. Anschließend müssen Sie eine (oder auch mehrere) e-mail-Adressen für diesen Alias eintippen.
    Haben Sie eine Mail markiert, können Sie auch den Menüpunkt Special / Make Nickname verwenden, um den Absender direkt in die Nicknameliste aufzunehmen.

    Wenn Sie eine Mail verschicken, brauchen Sie dann im "To: - oder Cc: - Feld" nicht mehr die komplette e-mail-Adresse einzutragen. Es genügt das entsprechende Kürzel. Oder Sie drücken , wählen per Mausklick den Adressaten aus und drücken den To: - bzw. Cc: - Knopf.


Wenn mehrere Benutzer auf einem PC arbeiten

... können verschiedene Benutzerverzeichnisse eingerichtet werden, so daß jeder unabhängig vom anderen seine Mails verwalten kann. Beim Start von Eudora muß dann das entsprechende Benutzerverzeichnis als Parameter angegeben werden. Am besten richtet man für jeden Benutzer ein Icon ein.
Beispiel: Der Benutzer Müller habe ein Verzeichnis C:\MUELLER, in dem er seine Mails ablegen will. Eudora befinde sich im Verzeichns C:\EUDORA. Für das entsprechende Icon trägt man dann unter den Programmeigenschaften als Befehlszeile ein:
C:\EUDORA\EUDORA.EXE C:\MUELLER .

Jeder Benutzer muß einmal seine persönlichen Einstellungen eingeben. Eudora fordert dazu aber auf, wenn das Programm zum ersten Mal mit einem neuen Verzeichnis gestartet wird..


3.5 Telnet

Auch wenn Sie eine SLIP-Verbindung unter Trumpet-Winsock haben, können Sie sich bei lehrer1 einloggen und UNIX-Befehle an Ihrem Systemprompt eingeben. Dafür brauchen Sie ein Telnet-Programm wie EWAN.
EWAN erhalten Sie als ZIP-Datei z. B . von ftp://warum.uni-mannheim.de/systems/windows/winsock.
EWAN1052.ZIP wird mit PKUNZIP.EXE ausgepackt. Dann starten Sie unter Windows das INSTALL-Programm und erhalten eine Windowsgruppe mit einem Icon für das Programm.

EWAN ist sehr einfach zu bedienen. Beim Start erscheint das Connect to site - Fenster
(das auch unter dem Menüpunkt File / Open erscheint). Wählen Sie hier den Button New und machen Sie folgende Eintragungen:

Bestätigen Sie zweimal mit ok. Sie werden automatisch eingeloggt und können weitermachen, wie in Kapitel 1.2 ff beschrieben.
Allerdings kommt Ewan mit dem Scrolling von Vollbildeditoren wie joe nicht zurecht. Hierfür sollten Sie sich mit DOS-Kermit einloggen.
Wenigstens "nach links löschen" sollte aber funktionieren, damit Sie Tippfehler am Systemprompt korrigieren können. Dafür müssen Sie noch eine kleine Einstellung vornehmen:

1. Wählen Sie den Menüpunkt
Options / Configuration....
Drücken Sie dann auf den Knopf
Emulation und stellen Sie sicher
daß DEC-VT 100 eingestellt ist.
Bestätigen Sie mit ok.
2. Drücken Sie dann den Knopf
Emul. Options und löschen Sie
das Kreuz im ersten Kästchen.

In Zukunft müssen Sie nach dem Start von EWAN Uni-Karlsruhe nur noch mit ok bestätigen.

Unter Windows 95 können sie auch das vorhandene Telnet-Programm Telnet.exe verwenden, das sich normalerweise im Windows-Verzeichnis befindet.


[zum Index] [Vorige] [Nächste] .................... Anleitungen für die za...'s


Thomas Mühlbayer Letzte Änderung: 14.6.1997